Jump to content
Sign in to follow this  
Guest

Wind Turbines...?

Recommended Posts

Guest

Looks like AirX then! Who's the best to get one from? I saw no comments on those chinese copies? They have some nice features!!! They say "boat" use but not the magic word "marinised"...600 bucks is I assume a lot less to pay than an AirX?

Share this post


Link to post
Share on other sites
Guest

Righto..will popup from time to time to see if he's on..in the meantime..a box of cherries and homemade coconut rum!!..... 8)

Share this post


Link to post
Share on other sites

Hi Guys, Sorry (well, not really!) I've been out sailing, and outside the cellular area. WD, I sent you a PM. Give me a call if you wan to talk further, technical, selection, whatever. Allways happy to talk boats!

Cheers

Matt

0221539176

Share this post


Link to post
Share on other sites
Hi Guys, Sorry (well, not really!) I've been out sailing, and outside the cellular area. WD, I sent you a PM. Give me a call if you wan to talk further, technical, selection, whatever. Allways happy to talk boats!

Cheers

Matt

0221539176

 

 

 

:twisted:

 

We are all awaiting to read your answer/opinion on here! :D

Share this post


Link to post
Share on other sites

OK then Ash, here is the gist of it;

 

My experience with wind gens over 15 years and 30,000 miles + is this. (Feel free to disagree, but this is my opinion)

 

What you want is max power output, quiet, and low start-up speeds. + reliable of course!

 

We currently have an Air Breeze. The Air X is no longer in production - we had one of those, and replaced it with an Air Breeze when it (the Air X) exploded off the Ausy coast in 50 Knots. The Braking system failed. The Air X was good (esp in Wellington), and I have seen it produce nearly 40 amps! However, it's startup speed was high, so it only really worked when it was pretty windy, and it was noisy - screamed like a banshee in over 40 Knots, louder than the wind!! Noisy in an anchorage...

 

The Air Breeze, being the replacement for the Air X, was supposed to fix those issues, but at the same time the power output was substantially reduced. This was to circumvent their most common failure - the braking system/electronic control board. The most output I've ever seen out of our Air Breeze is about 15 amps. So it's not fantastic.

 

Both the Air X and the Air Breeze can be substantially quietened by replacing the blades with the Blue ones from Silent Wind. But they are expensive... This is what we did, as, at the time, SilentWind did not yet make a whole generator.

 

However, with the Silent Wind blades, we are very commonly asked why our wind gen is working and or quiet, when another cruisers is not going or noisy. It is rare to be able to hear our wind gen from another vessel at anchor. Of course though, it is not "silent" as the name suggests, just comparatively quiet. The noise level of our Air Breeze, with the Silent blades, is equivalent to the new Silent Wind Gen turbine, which of course comes with these blades!

 

Now, I'd buy their ( Silent Wind) Generator. Max output 450w, (2 x the Air Breeze output) low startup speed and Quiet!! The Silent Wind is a bit pricey, (not the most expensive though) - IMO it's the best there is for practical use, and still cheaper than the Air Breeze with replacement blades... Most of the other brands cannot compete on all three main fronts - Output, Startup speed, and noise. That is why I have chosen this brand to resell now. They are also good to deal with, (service and support)

 

Wind turbines are not the final answer. In the higher Lats, people tend to spend time anchored in spots out of the wind, so get little out of them. In tradewind areas, they are great, and can provide all the power you need. Near the equator they are almost useless - no wind! Combined with good batts and solar panels, they can be a great solution.

 

My Wind Gen section is http://www.neptunes-gear.com/collections/wind-generators

 

Happy to talk to anyone interested...

 

Cheers

Matt

Share this post


Link to post
Share on other sites
Guest

I'm having real issues with mine at the moment. It's been going for the last 2 weeks and as yet knot one tiny amp of output.

post-646-14188726275.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...